Telegram Posting

Telegram Posting 1.6.7 Beta

vjpitbul

New member
Не в сети
Здравствуйте, такая проблема, что при заходе в настройку плагина выдает ошибку: HTTP ERROR 500
 

emily211

New member
Не в сети
Добрый день

после установки плагинов такая ошибка при запросах в mysql, как это можно решить?

Ошибка: у вас есть ошибка в синтаксисе SQL; проверьте руководство, соответствующее вашей версии сервера MySQL, чтобы найти правильный синтаксис для использования рядом с 'table dle_telegram_cron (cron_id int auto_increment primary key' в строке 1
 

Вложения

  • XF:Attachment[515] Screenshot_1.jpg
    Screenshot_1.jpg
    165.6 KB · Просмотры: 49
  • XF:Attachment[516] Screenshot_2.jpg
    Screenshot_2.jpg
    104.8 KB · Просмотры: 49
Последнее редактирование модератором:
АТ
Maxim

Maxim

Active member
Команда форума
Не в сети
Только что проверил, встало всё без проблем. Смотрите логи пхп и апача. проверил на 14.х и 15.0
 

SashaShy

New member
Не в сети
Поставил telegram Posting 1.6.7 и есть проблема с функцией load_data. Кеш создает, но если внес изменения в новость, то изменения в кеше не обновляются/появляются. Можно ли как-то добавить проверку (если доп. поле не такое, как в кеше то обновить весь файл) для внесения изменения в кеш или хоть возможность отключить кеширование?
И есть проблема с тегами dle, таким как {category} и [if field = "значение"] текст [/if], просто не обрабатываются.
Версия dle 14.3
 
АТ
Maxim

Maxim

Active member
Команда форума
Не в сети
@SashaShy, я был на семинарах, поэтому долго не отвечал. Вернулся с ангиной 😅 . я попробую выделить время, чтобы проверить всё.

есть проблема с функцией load_data
просто очисти кеш системы, функция использует стандартный функционал DLE. В админке бывает нужно удалять кеш браузера (CTRL+F5). С чем это связано - без понятия, ибо так сильно я не извращался над кешированием.
хоть возможность отключить кеширование
постараюсь встроить, над новой версией уже начал работать

{category} и [if field = "значение"] текст [/if]
проверю в чём дело, как только смогу
 

Nokian

NORDMAN
Не в сети
Добрый день! Помогите решить проблему

  1. DLE 15, PHP 7.3
  2. Установил MyAssets 1.7.0.1 ( https://devcraft.club/downloads/maharder-assets.4/version/1/download )
  3. Установил Telegram Posting 1.6.8 beta ( https://github.com/Gokujo/telegramposting/archive/refs/tags/1.6.7_beta.zip )
  4. Настроил подключение к боту, тестовое сообщение ушло.
  5. Создал доп.поле - telegraminform, Переключатель 'Да' или 'Нет'
  6. В зависимостях указал - Прочее() xf:telegraminform|1 , пробовал и просто выбрать это доп.поле в списке зависимосте и поставил значение 1.
  7. Сделал все изменения в файлах, как указано в настройках модуля.
[Wed Dec 08 10:28:45.742618 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: PHP Fatal error: Uncaught Error: Class 'Intervention\\Image\\ImageManagerStatic' not found in /home/nkn/web/my-domain.ru/public_html/engine/classes/thumb.class.php:84, referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

[Wed Dec 08 10:28:45.742660 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: Stack trace:, referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

[Wed Dec 08 10:28:45.742669 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: #0 /home/nkn/web/my-domain.ru/public_html/engine/inc/maharder/telegram/assets/telegram.class.php(638): thumbnail->__construct('/home/nkn/web...'), referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

[Wed Dec 08 10:28:45.742677 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: #1 /home/nkn/web/my-domain.ru/public_html/engine/inc/maharder/telegram/assets/telegram.class.php(683): processImage('/home/nkn/web...'), referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

[Wed Dec 08 10:28:45.742685 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: #2 /home/nkn/web/my-domain.ru/public_html/engine/inc/maharder/telegram/assets/telegram.class.php(346): Telegram->generateThumb('\\xD0\\xA2\\xD0\\xB5\\xD1\\x81\\xD1\\x82 4'), referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

[Wed Dec 08 10:28:45.742693 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: #3 /home/nkn/web/my-domain.ru/public_html/engine/inc/maharder/telegram/assets/telegram.class.php(56): Telegram->processContent('\\xD0\\xA2\\xD0\\xB5\\xD1\\x81\\xD1\\x82 4', Array), referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

[Wed Dec 08 10:28:45.742702 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: #4 /home/nkn/web/my-domain.ru/public_html/engine/inc/maharder/telegram/editnews.php(31): Telegram->__construct(7, Array, 'editnews'), referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

[Wed Dec 08 10:28:45.742709 2021] [fcgid:warn] [pid 5055] [client 94.127.221.137:60600] mod_fcgid: stderr: #5 /home/nkn/web/my-domain.ru/public_html/engine/cache/system/plugins/4d in /home/nkn/web/my-domain.ru/public_html/engine/classes/thumb.class.php on line 84, referer: https://my-domain.ru/admin.php?mod=editnews&action=editnews&id=7

Новая новость просто создаётся, а если изменяю уже опубликованную, то ошибка 500 выскакивает. Сначала думал, что формат изображений Webp не поддерживается для постинга, но потом попробовал jpg и png, результат такой же. Отключил вывод сообщений с постером, сделал текстовый и попробовал просто отправить заголовок {title}, но результата нет никакого. Куда смотреть, что делать, подскажите :unsure:
 
Последнее редактирование:
АТ
Maxim

Maxim

Active member
Команда форума
Не в сети
Примерно понял в чём проблема. На выходных гляну на тестовом сервере. раньше никак.
 
АТ
Maxim

Maxim

Active member
Команда форума
Не в сети
Проблему нашёл, видать с 14.2 был обновлён класс создающий миниатюрки. в 14.1 не было зависимостей от композера. сейчас ещё и пару функций убрали. работаю над исправлением.
 

Somon007

New member
Не в сети
Fatal error: require_once(): Failed opening required '/var/www/topfile/engine/inc/maharder/assets/functions.php' (include_path='.:/usr/share/php') in /var/www/topfile/engine/inc/telegram.php on line 21 - пишет такую ошибку ( в чем может быть проблема?
 

mndlrd

New member
Не в сети
Привет народ, помогите настроить

Сделал доп поле с переключателем ДА/НЕТ (по умолчанию стоит ДА) и хочу чтобы при нажатии на НЕТ постинга в тг не было. Где что нужно поставить? Спасибо за помощь!
 

Вложения

  • XF:Attachment[517] 1642191549868.png
    1642191549868.png
    64.4 KB · Просмотры: 15
Последнее редактирование модератором:
АТ
Maxim

Maxim

Active member
Команда форума
Не в сети
Ошибки я все собрал, работаю над новой версией
 
АТ
Maxim

Maxim

Active member
Команда форума
Не в сети

Добавил видео по настройке модуля. Мне жаль, что не могу всем ответить во время. Но, расписывать каждому одну и ту же деталь - времени нет
 

vjpitbul94

New member
Не в сети
почему то в админке так отображается

и как узнать именно ТОКЕН канала, который я создал, нужно создать бот или как? ссылка не работает в админке, где указана инструкция как узнть
 

Вложения

  • XF:Attachment[638] 1212.png
    1212.png
    74.5 KB · Просмотры: 6

sokol8611

New member
Не в сети
Дорогие форумчане помогите пожалуйста. Установил модуль. Тестовое сообщение отправляется а при создании новости стараница пустая как будто сайт не доступен. Крон при этом выключен. А если крон включен то новость добавляется но всё равно в телегу ничего не отправляется и в кроне ну в списки на отправку копятся новости в чём может быть дело? Сайт расположен в России . Пожалуйста помогите кто может?!
Сообщение автоматически объединено:

Пожалуйста напишите мне в телеграмм ребята пожалуйста у кого данный модуль работает https://t.me/sokoldag
 
Сверху